5ヶ月くらい前から、MacPortsのsubversionが1.8にバージョンがあがっているのですが、こいつが、unicode_path パッチに対応しておらず、日本語ファイルを扱う環境だと問題があります。
・・・みんな困ってないのでしょうか。

とりあえずの対処としては、1.7系の最終版である、1.7.10を使います。
手順は以下:

まず、1.8 の subversion をアンインストール
> sudo port uninstall subversion

どっかワーキングディレクトリをつくってそこで作業
> mkdir tmp
> cd tmp

リビジョンを指定して port から co
> svn co -r 106653 http://svn.macports.org/repository/macports/trunk/dports/devel/subversion

ビルド
> cd subversion
> sudo port install +unicode_path

 

【ディーゴでは各種システム開発を承っております(下北沢・世田谷・東京)】
http://www.deego.co.jp/